Waja Campro Owner Club

Everything On Camproz..
 
HomeFAQSearchRegisterMemberlistUsergroupsLog in

Share | 
 

 Help: Tweeter problem

Go down 
AuthorMessage
cooldog8236



Male
Number of posts : 21
Age : 37
Localisation : Kuantan
Registration date : 2007-03-25

PostSubject: Help: Tweeter problem   Fri Mar 30, 2007 1:38 pm

hey guy, i got a little problem here. my tweeter on the left side of the dashboard seems to sound chit-chit-chit. sometimes very2 loud chit-chit sound like the tweeter already rosak, sometimes not so noticable but very soft chit-chit sound is there, but sometimes ok,working fine and no chit-chit sound. what's wrong with it???
Back to top Go down
View user profile
cooldog8236



Male
Number of posts : 21
Age : 37
Localisation : Kuantan
Registration date : 2007-03-25

PostSubject: Re: Help: Tweeter problem   Fri Mar 30, 2007 1:41 pm

sorry bro, i dunno y got 2 same post here. sumone help me delete 1 of it. thanks.
Back to top Go down
View user profile
nickster82
Admin


Male
Number of posts : 79
Age : 36
Localisation : Kuala Lumpur, Malaysia
Registration date : 2007-03-25

PostSubject: Re: Help: Tweeter problem   Fri Mar 30, 2007 4:04 pm

Do you play your music loud? I had the same problem with my stock speakers previously. The cause was putting my music too loud! haha!

My solution was to upgrade and change my whole sound system! Razz

Perhaps, you can also consider! hehe!

Anyway, changing the front tweeters is cheap! They do not cost much! Unless, you want to upgrade to high-end sound system la!
Back to top Go down
View user profile
cooldog8236



Male
Number of posts : 21
Age : 37
Localisation : Kuantan
Registration date : 2007-03-25

PostSubject: Re: Help: Tweeter problem   Fri Mar 30, 2007 9:45 pm

nick, i recently change my HU and added an 800w amp 2 days ago. maybe those guys when installing that time blast too loud when testing the sound.

i went back to the shop just now and that guy said my tweeter not good. the speaker is still ok. i not yet change the tweeter, coz he ask me go home n try few days again c got the cit-cit sound.

nick, u change all the speakers n stuff?? which brand u get n how much????
Back to top Go down
View user profile
nickster82
Admin


Male
Number of posts : 79
Age : 36
Localisation : Kuala Lumpur, Malaysia
Registration date : 2007-03-25

PostSubject: Re: Help: Tweeter problem   Mon Apr 02, 2007 11:25 am

Cooldog...What HU and amp did you get? The stock tweeters that we have are not good. They break easily! So you cant get good sounds and play loud music with them!

My whole system is from the Sony xPlod Series. I am a beginner with these things. So i did not want to go through the hassle of pick and matching! Below is the list of stuff i got so far:-

Head Unit (HU): CDX - GT800D
Front Speakers: XS - HF167 (6 1/2" Component Separates)
Back Speakers: XS - HT170SN (6 1/2" Component Separates)
Woofer: LD125P5 (12" Component Subwoofer)
Amplifier: XM-SD51X (Monoblock - Subwoofer Amplifier)
Accessories: GMD-700 (Auxilary Tray - for MP3 players and IPOD)

I still need another amp to power up my mid! My HU is powering this at the moment…tak cukup ommph la! Haha! Am planning to get the 'XM-SD46X' (4 channel amp) soon. Currently i am tight on budget la! Sigh!

Anyway, I will post some pics soon. Let me find my camera first! Razz


Last edited by on Mon Apr 02, 2007 11:38 am; edited 1 time in total
Back to top Go down
View user profile
nickster82
Admin


Male
Number of posts : 79
Age : 36
Localisation : Kuala Lumpur, Malaysia
Registration date : 2007-03-25

PostSubject: Re: Help: Tweeter problem   Mon Apr 02, 2007 11:31 am

Btw, if you are interested to check out and know more about the stuff i use...you can visit the links below:

http://www.xplodsony.com/specialty/speakers/XS-HF167

http://www.xplodsony.com/specialty/subwoofers/XS-LD125P5

http://www.sony.com.my/sonystyle/product/productinfo_xplod.asp?Subcategoryid=71
(Sony Style Malaysia Website – All the other stuff can be found and seen here)

I am quite happy with my system! Sony makes great Component Speakers. The sounds are very very clear! Just need one more amp la! Sigh! haha!

Um, it seems like I am promoting Sony Stuff here! haha! Razz
Back to top Go down
View user profile
cooldog8236



Male
Number of posts : 21
Age : 37
Localisation : Kuantan
Registration date : 2007-03-25

PostSubject: Re: Help: Tweeter problem   Tue Apr 03, 2007 4:33 pm

nick, u so rich la. change sony worr. My HU is from AVT. model is R-6088. I never heard of this brand b4, but my uncle recommend me to get this. amp, my old amp is 2 chan, ayam brand but now i'm getting a 4 chan amp. my uncle make a booking for me this morning, n i didn't ask him what brand la. ATM, he borrow me rockford amp this few days till my new amp arrived. btw, my uncle have been in this sound system industry for decades, so i let him pick n match for me. I'm new to all this too, so i have no idea how to pick n match. so i just trusted him n let him decide.

I might change my front speakers. can't play the music too loud. got some weird sound coming out . since u say sony good, i want to try out sony too. but now i'm also tight on budget.
Back to top Go down
View user profile
nickster82
Admin


Male
Number of posts : 79
Age : 36
Localisation : Kuala Lumpur, Malaysia
Registration date : 2007-03-25

PostSubject: Re: Help: Tweeter problem   Wed Apr 04, 2007 2:16 pm

Hey bro...i not rich la! All my money gone b'cos of this! Now very broke! haha!

AVT...first time i heard this brand. Just visited their website and it seems to be a Filipino company. You know abt it? I am not so sure la.

Yer uncle should be able to recommend you the right stuff, since he is in this for so long! We must listen to him and get advise! hehe!

Btw, he owns a Car Audio shop or he just likes playing with ICE?

Anyway, you should change yer front speakers la. The stock ones..really cannot tahan! Without amp, already pecah! If put amp...sure pecah lor! haha!

If you tight on budget, it is recommended that you just change your front speakers to 'component set' and back speakers to '3-way speakers'...plus one amp! Cukup! Smile

With '3-way' speakers...you have the bass, tweeter and mid all built-in. So with a good '4-channel' amp...i think you will have sufficient bass and sound. However, not as much bass as having a subwoofer la! But, with subwoofer...you need another amp also!

What is yer budget like?
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Help: Tweeter problem   

Back to top Go down
 
Help: Tweeter problem
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Waja Campro Owner Club :: Miscellaneous :: Car Troubleshot Discussion-
Jump to: